Kies een geschikte webhost voor Zen Cart

Web Hosting is de service die er voor zorgt dat uw web-site zichtbaar is voor andere mensen op het internet.

Zen Cart® bied gecertificeerde Webhosts aan, die hebben toegezegd zeer goede klantenservice te geven aan al hun klanten en er voor te zorgen dat hun servers geschikt zijn om Zen Cart® te draaien zonder dat er aanpassingen nodig zijn aan het programma. Als u een gecertificeerde host kiest, helpt u ook om Zen Cart® verder te kunnen ontwikkelen, aangezien deze hosts ook hebben toegezegd het Zen Cart® project financieel te steunen.

Wij maken zelf vaak gebruik van Your Hosting voor shared hosting, of van onze eigen VPS servers voor VPS Hosting, of speciale oplossingen.

Een goede test om te kijken hoe goed de klantenservice is van een hostingbedrijf, is om ze een e-mail te sturen en te kijken hoe lang het duurt voor ze reageren. U kunt op internet ook zoeken in forums, beoordelingen en informatie over de betreffende host. De prijs is natuurlijk ook belangrijk, maar in de wereld van hosting is het vaak zo dat je krijgt waarvoor je betaald.

Zen Cart® v1.5.4

De minimale server configuratie is:

  • Zen Cart 1.5.4 is ontworpen voor PHP 5.5 en PHP 5.6. (Maar is compatibel met PHP 5.3.7 en PHP 5.4 als het echt moet, met een aantal speciale patches.)
  • Apache 2.x en nieuwer (Bij voorkeur de laatste PCI overeenstemmende versie)
  • MySQL 5 en hoger (wederom, gebruik een PCI overeenstemmende versie)
  • Register Globals off (Deze optie is verouderd in PHP 5.4 en nieuwer)
  • PHP Safe_Mode = off (Deze optie is verouderd in PHP 5.4 en nieuwer)
  • Het up-to-date houden van deze onderdelen wordt aangeraden voor PCI Compliance en algehele veiligheidsredenen.

Zen Cart® v1.5.5

De minimale server configuratie is:

  • Zen Cart 1.5.4 is ontworpen voor PHP 5.5, PHP 5.6 en PHP 7.0. (Optineel compatibel met PHP 5.3.7 en PHP 5.4 als het echt moet, met een aantal speciale patches.
  • Apache 2.x en nieuwer (Bij voorkeur de laatste PCI overeenstemmende versie)
  • MySQL 5 en hoger (wederom, gebruik een PCI overeenstemmende versie)
  • Register Globals off (Deze optie is verouderd in PHP 5.4 en nieuwer)
  • PHP Safe_Mode = off (Deze optie is verouderd in PHP 5.4 en nieuwer)
  • Het up-to-date houden van deze onderdelen wordt aangeraden voor PCI Compliance en algehele veiligheidsredenen.

Notes

  • CURL
    Veel verzend- en betaalmodules vereisen dat CURL is geïnstalleerd en gecompileerd met PHP.
  • SSL & HTTPS
    Ondersteuning voor HTTPS kan voor bepaalde betaalmethodes verplicht zijn. Het gebruk van SSL tijdens het aanmaken van een account en tijdens de checkout is in Nederland verplicht. Als SSL is geconfigureerd en is aangezet in uw webwinkel, zal Zen Cart® dit automatisch activeren op de schermen gerelateerd aan Login, My Account en Checkout.
  • PHP als CGI
    Als u een host hebt die op Unix/Linux draait, met PHP draaiend als CGI, kunt u moeilijkheden tegenkomen. In Linux, tenzij uw host PHP in "suPHP" mode goed kan configureren, wordt het aangeraden om PHP te gebruiken als een Apache module, niet als een CGI app, tenzij u server-level controle hebt of de vergaande kennis hebt van de CGI opties en over het instellen van een server om optimaal te functioneren.
  • MySQL5
  • MySQL 5 heeft een aantal strengere beperkingen van de verschillende SQL-statement constructies. Zen Cart® v1.3.9, en nieuwer, werken prima met MySQL5.
    Zen Cart 1.5.5 verwacht MySQL 5.1 tot MySQL 5.7
  • Zen Cart v1.5.1 en eerdere versies worden officieel niet langer ondersteund.

PHP versie compatibiliteit

PHP4
Zen Cart® v1.3.x+ met een PHP versie lager dan 4.3.2 zal resulteren in problemen met het behouden van sessies. Zen Cart® v1.5.0 en nieuwer zullen NIET werken op PHP4.

  • Zen Cart® v1.3.7 en ouder
    Werken alleen met PHP4
  • Zen Cart® v1.3.8
    Het is het beste om PHP 4 te gebruiken, maar het kan tot en met PHP versie 5.2.x.
  • Zen Cart® v1.3.9
    PHP4 is mogelijk, maar PHP5 wordt aangeraden. Gebruik PHP 5.2.3 of nieuwer, of PHP 5.3.2 en nieuwer. PHP 5.4 wordt niet ondersteund.
  • Zen Cart® v1.5.0
    Gebruik PHP 5.2.3 en nieuwer, of PHP 5.3.2 en nieuwer of PHP 5.4 en nieuwer. GEBRUIK NIET ouder dan PHP 5.2.3 (geen PHP4)

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

Deze website gebruikt Akismet om spam te verminderen. Bekijk hoe je reactie-gegevens worden verwerkt.